Chat with us, powered by LiveChat

How can we help you?

Information Centre




image

Message Detail

flag
faq
rnr
tnc

Please ensure that you are logging in from a non-restricted country. Adding, kindly clear all your cookies/cache and close browser. Then, open again the browser and try again.

If your login is still unsuccessful, kindly re-check that you have entered the correct information and try again. If you are still unable to log in, please contact DB888's Customer Service Support Live Chat.

Different kinds of aspects technical safety, hence, below are DB888's major precautions that have been established. Physical safety - Our servers are placed in highly protected premises, where all employees have been screened with security clearance. Security breach protection - Our servers are protected by firewall system. Data integrity - All DB888's communication between your browser and our servers is encrypted.

DB888 recommends Operating Systems, Browsers and Adobe Flash on below details:

Screen Resolution

For optimal use of the website, please ensure your screen resolution is set to 1024 x 768 or higher. Please refer to Optimum Screen Resolution to assist you in checking and adjusting your screen resolution if required.

Windows 7, Vista

- Internet Explorer 7 or later (download IE 9)

- Mozilla Firefox 2.0.0.20 or later

- Opera 9.01 or later (download Opera 11.51)

- Google Chrome (download Google Chrome)

 

Windows XP

- Internet Explorer 6 or later (download IE 8)

- Mozilla Firefox 2.0.0.20 or later

- Opera 9.01 or later (download Opera 11.51)

- Google Chrome (download Google Chrome)

 

Windows 2000

- Internet Explorer 5.5 or later (download IE 6)

- Mozilla Firefox 2.0.0.20 or later

- Opera 9.01 or later (download Opera 11.51)

 

Windows ME, 98

- Internet Explorer 5.5 or later (download IE 6)

- Mozilla Firefox 2.0.0.20

- Opera 9.01 or later (download Opera 11.51)

 

Mac OS X 10.4 or later

- Safari 2.0.3

- Mozilla Firefox 2.0.0.20 or later

- Google Chrome (download Google Chrome)

 

Mac OS X 10.3 or earlier

- Mozilla Firefox 2.0.0.20

 

Adobe Flash

DB888 advise using Adobe Flash version 9.0.115 or later. To check to see if you have a suitable version of Adobe Flash Player, click 'Check my Flash version' which will launch a pop up window advising that 'You have the required version of Adobe Flash Player installed' meaning that you have the latest version of Flash and therefore need take no further action; or alternatively a pop up will ask you to install and run the latest version of Flash. This is strongly recommended.

We notice that a few features will be missing if you are using IE8 or lower since there is a limited support from Microsoft regarding to latest version of HTML5, CSS3, jQuery2.0, etc. Thus, please use higher IE version to have full usage.

If you continue to experience problems, please contact DB888's Customer Service Support Live Chat if we can be any of assistance 24/7.